Πανελλήνιες 2021: Απαντήσεις στα θέματα στο μάθημα της Πληροφορικής

18/06/2021 11:06
Πανελλήνιες 2021: Απαντήσεις στα θέματα στο μάθημα της Πληροφορικής

Στο μάθημα της Πληροφορικής εξετάστηκαν οι μαθητές στις Πανελλήνιες Εξετάσεις την Παρασκευή 18 Ιουνίου:

Δείτε αναλυτικά της απαντήσεις στο μάθημα της Κοινωνιολογίας:

 

ΘΕΜΑ_Δ

Δ1α
ΜΕΤΑΒΛΗΤΕΣ
    ΧΑΡΑΚΤΗΡΕΣ:ΟΝ[20]
ΛΟΓΙΚΕΣ:ΒΡ
    ΑΚΕΡΑΙΕΣ:Ι , J , K , ΠΛ_ΑΘΛ ,ΑΛΜΑ
    ΠΡΑΓΜΑΤΙΚΕΣ:ΕΠΙΔ[20,6] , ΜΕΓ , ΤΕΜP
ΑΡΧΗ
Δ1β
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
ΔΙΑΒΑΣΕ ΟΝ[Ι]
Δ1γ
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
    ΔΙΑΒΑΣΕ ΕΠΙΔ[I,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Δ2
ΜΕΓ ΕΠΙΔ[1,1]
ΑΛΜΑ1
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
    ΑΝ  ΕΠΙΔ[I,J]> ΜΕΓ ΤΟΤΕ
            ΜΕΓ ΕΠΙΔ[I,J]
ΑΛΜΑJ    
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘Η ΜΕΓΑΛΥΤΕΡΗ ΕΠΙΔΟΣΗ ΠΟΥ ΣΗΜΕΙΩΘΗΚΕ ΕΙΝΑΙ :’,ΜΕΓ,’ ΣΤΟ ‘,ΑΛΜΑ,’ο ΑΛΜΑ’
Δ3 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΠΛ_ΑΚ 0
J1
ΒΡΨΕΥΔΗΣ
ΟΣΟ J<=6 ΚΑΙ ΒΡ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΕΠΙΔ[I,J]=0 ΤΟΤΕ
        ΠΛ_ΑΚ ΠΛ_ΑΛ+1
        ΑΝ ΠΛ_ΑΚ=2 ΤΟΤΕ
            ΒΡΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
        JJ+1
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΒΡ=ΑΛΗΘΗΣ  ΤΟΤΕ
    ΓΡΑΨΕ ΟΝ[Ι]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Δ4
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
ΓΙΑ Ι  ΑΠΟ 2 ΜΕΧΡΙ 6
    ΓΙΑ J ΑΠΟ  6 ΜΕΧΡΙ  I ME BHMA -1
        ΑΝ ΕΠΙΔ[K,J-1]< ΕΠΙΔ[K,J] ΤΟΤΕ
            TEMP ΕΠΙΔ[K,J]
ΕΠΙΔ[K,J] ΕΠΙΔ[K,J-1]
            ΕΠΙΔ[K,J-1]TEMP        
        ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Δ5
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
ΓΡΑΨΕ  ΟΝ[Ι]
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ ΕΠΙΔ[I,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Μέχρι το τέλος των Πανελλαδικών Εξετάσεων, το ethnos.gr θα δημοσιεύει τις απαντήσεις των θεμάτων των σε συνεργασία με το «Νέο Φροντιστήριο» και την ομάδα των καθηγητών του.

Νέο Φροντιστήριο: 53 χρόνια επιτυχίες

Ο όμιλος Νέο Φροντιστήριο, ιδρύθηκε το 1968 & σήμερα  αριθμεί πάνω από 80 εκπαιδευτικά κέντρα με 600 καθηγητές, 100 συνεργάτες διευθυντές σπουδών κάθε ειδικότητας, πλήρη σειρά εκδόσεων και πλούσιο ηλεκτρονικό εκπαιδευτικό υλικό. Η πλούσια ακαδημαϊκή του παράδοση διατηρείται αναλλοίωτη, αφού οι άνθρωποι του βρίσκονται σε συνεχή εγρήγορση αφουγκραζόμενοι τις νέες εξελίξεις & προκλήσεις της εποχής, κάτι που επιβεβαιώθηκε περίτρανα στην πρόσφατη περιπέτεια της πανδημίας.   Η  διαχρονική πρωτοκαθεδρία του οργανισμού στην προετοιμασία των μαθητών για την τριτοβάθμια εκπαίδευση, ανεξαρτήτως του τρόπου εισαγωγής τους, καταδεικνύεται από τα αποτελέσματα, αφού κάθε χρόνο πάνω από 1200 μαθητές των  φροντιστηρίων μας εισάγονται στην Τριτοβάθμια Εκπαίδευση. Υπολογίζεται ότι πάνω από 60

Όλες οι ειδήσεις

Δολοφονία στα Γλυκά Νερά: Η οδηγία στο εγχειρίδιο του FBI που «έδειξε» τον δράστη

Πανελλαδικές 2021: Τα θέματα σε Κοινωνιολογία, Πληροφορική, Χημεία

Δολοφονία στα Γλυκά Νερά: Πώς «έσπασε» ο πιλότος - Τι ανέφερε στην ομολογία του

Υποχρεωτικός εμβολιασμός: Στο Μαξίμου το πόρισμα της Επιτροπής Βιοηθικής - Τι προβλέπει

πηγή